FirmwareAnpassungen

Wie kann ich ...

einen Gateway einrichten?

http auf WAN Port verfügbar machen

LAN und WAN Port tauschen

Firmware aktualisieren

Configmode per SSH aktivieren

Pakete per opkg nachinstallieren?

Lan Ports aufteilen in Vlans

Routereinstellungen per ssh ändern

Noch mehr Sachen per ssh ändern

TP-Link 3600 Recovery

Router per ssh zurücksetzen (restore)

umount /overlay && firstboot && reboot

Standort in Map anpassen

uci set gluon-node-info.@location[0].share_location='1'
uci set gluon-node-info.@location[0].longitude='9.3801'
uci set gluon-node-info.@location[0].latitude='48.819'
uci commit

Node auf einen Gateway fest binden

uci set fastd.mesh_vpn_backbone_peer_gw01.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw02.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw03.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw04.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw05.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw06.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw07.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw08.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw09.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw10.enabled='0'
uci set fastd.mesh_vpn_backbone_peer_gw07.enabled='1'
/etc/init.d/fastd restart
uci set fastd.mesh_vpn_backbone.auto_segment='0'
uci set fastd.mesh_vpn_backbone_peer_gw07.remote='"gw07n01.ffs.ovh" port 10213'
/etc/init.d/fastd restart

Mesh on VLAN

Einfügen in /etc/config/network

3600v1/4300/v1: vlan9 /Mesh on Vlan

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 1t 2t 3t 4t 5t'

config interface 'mesh_vlan'              
        option ifname 'eth0.9'            
        option auto '1'                   
        option proto 'gluon_mesh'           
        option fixed_mtu '1'              
        option transitive '1'

841 v8: Port 1+2 (2t+3t) haben vlan9 /Mesh on Vlan

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config interface 'wan'                    
        option ifname 'eth0.1'   

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 2t 3t'

config interface 'mesh_vlan'
        option ifname 'eth0.9'
        option auto '1'
        option mesh_no_rebroadcast '1'
        option mesh 'bat0'
        option proto 'batadv'

841 v9

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config interface 'wan'                    
        option ifname 'eth1.1'   

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 1t 2t 3t 4t 5t'

config interface 'mesh_vlan'
        option ifname 'eth1.9'
        option auto '1'
        option mesh_no_rebroadcast '1'
        option mesh 'bat0'
        option proto 'batadv'

Allgemein

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config interface 'wan'                    
        option ifname 'eth1.1'   
	...

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 1t 2t 3t 4t 5t'

config interface 'mesh_vlan'
        option ifname 'eth0.9'
        option auto '1'
        option mesh_no_rebroadcast '1'
        option mesh 'bat0'
        option proto 'batadv'

Neu FIrmware 1.0 841 b8

cat /lib/gluon/core/sysconfig/wan_ifname
echo eth1.1 > /lib/gluon/core/sysconfig/wan_ifname
echo eth0 > /lib/gluon/core/sysconfig/lan_ifname


config interface 'wan'
        option ifname 'eth1.1'
        ...

config interface 'client'
        list ifname 'eth0'
        ...

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '9'
        option ports '0t 2t'

config interface 'mesh_vlan'
        option ifname 'eth0.9'
        option auto '1'
        option proto 'gluon_mesh'
        option fixed_mtu '1'
        option transitive '1'

Direktausleitung am Node

/etc/hotplug.d/iface/90-direktausleitung:
test $(uci get gluon.direktausleitung) -eq 1 || exit 0
if [ "$ACTION" = "ifup" -a "$DEVICE" = "mesh-vpn" ]; then
 # direktausleitung aktivieren
  while [ "$seg" == "" ]; do
    # segment und gw auslesen
    seg=$(batctl gwl | grep "*" | cut -c 12-13)
    gw=$(batctl gwl | grep "*" | cut -c 16,19)
    sleep 1
  done
  segip=$(($((seg-1))*8))
  MYIP=10.190.$((segip+5)).255
  ip address add $MYIP/21 dev br-client
  logger -t direktausleitung "ip address add $MYIP/21 dev br-client"
  iptables -I FORWARD -i br-client -o br-wan -j ACCEPT
  logger -t direktausleitung "iptables -I FORWARD -i br-client -o br-wan -j ACCEPT"
  iptables -I FORWARD -i br-client -o br-client -j ACCEPT
  logger -t direktausleitung "iptables -I FORWARD -i br-client -o br-client -j ACCEPT"
  killall dhcrelay
  dhcrelay -q -i br-client 10.191.255.251 10.191.255.252 10.191.255.253
  logger -t direktausleitung "dhcrelay -q -i br-client 10.191.255.251 10.191.255.252 10.191.255.253"
  batctl gw server
  batctl gw | logger -t direktausleitung
  ip route add 10.190.0.0/15 dev br-client via 10.190.$segip.$gw metric 100
  logger -t direktausleitung "ip route add 10.190.0.0/15 dev br-client via 10.190.$segip.$gw metric 100"
fi
exit 0

/usr/lib/micron.d/ffs-direktgateway: 
*/5 * * * * /usr/sbin/ffs-direktgateway

/usr/sbin/ffs-direktgateway:
#!/bin/sh
# beste route ermitteln
gw=$(batctl gwl | grep MBit | awk '{print $2 $1}' | sort | tail -1 | cut -c 19,22)
if [ "$gw" != "" ] ; then
  ip route change 10.190.0.0/15 dev br-client via 10.190.96.$gw metric 100
  logger -t direktausleitung "ip route change 10.190.0.0/15 dev br-client via 10.190.96.$gw metric 100"
fi

Einstellungen anpassen

uci set ssid-changer.settings.enabled='0'
uci set wireless.radio0.distance='9000'
uci set wireless.radio1.distance='9000'

ssh Keys hinterlegen für Remotezugang

Router 7 Sekunden lang Reset drücken, nach dem Reboot des Routers ist dieser per http://192.168.1.1 erreichbar. In Expert - Remote die Keys eintragen. SInd 2 Zeilen

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC7+/EHqthRGWRYsI4RSGKWmcP8b5UUrAUVe1zqeqqndP/4401dJXKQu8LJwUxQt+UpVGk8/nYaVW0k8n8yFKwxD+578cK4MPWK2lXtozJrC60r+pJdCeu+00CH1HS7bWDBC+G5dQ054vc/43RDoVAX0CzlTDhgr7jNLD8V4d+Vv4RoPnFcX5BfkaA1upTt9FjpFc7qIsNf4RxD2wVaG4OlyjHFXycisLj12tjAVAnvyF9gGdHp1/03xAPMt/sNQeq9fqgyJK/uUveq+JLYWu1Om6oKMOzS4RVgHbjOR2unKocfbh/YfDtaGs5ZTS4cN+xOXdB6Zpog2RS4N2OmVtaH 5@freifunk-weinstadt.de
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDNpfOwEKHuTpSg1dRAabFIOhW/vxxribD11uDVjwQcZ07ZfjyOLat3SqNzZH40klUSriu1Qm/gQXyJ8dP3c4eXfTtyeXF2DCjGjt+xrbUMn1w/xGdnlj/fEIlk8KJ0deJjpbP6N7LROYQ0CAH2fQAV+SJdLoddGoYfrNLd9JWOnTAdSZqjR5XF1w3UNoj0Yt089ZyJfZodR0jy7qdmQXUxhjpTb785f0GH1oRnyZYJERcBmcK5vdgBLoRHta5fyGO2s9QDQyEOmkFVI1R9/Z7dlVC2q9aG0sLngNwG7DCy8Puegl3NDlbtYCgATIhQvXJxDWbAHJVjhLU0GvalIR2H 6@freifunk-weinstadt.de
Page last modified on 17 August 2019 16:54 Uhr